« Back to support home

What devices are compatible with the Sound mobile app?

For our newest apps to function properly, the following mobile operating systems are required:

  • iPhone iOS 7.0 or higher
  • Android OS 4.0 or higher (ice cream sandwich version or later)

Search for another topic

By clicking here, you’ll be leaving soundcu.com. Sound is not responsible for any external content and our privacy policy does not apply.

Cancel Accept